読者です 読者をやめる 読者になる 読者になる

しめ鯖日記

swift, iPhoneアプリ開発, ruby on rails等のTipsや入門記事書いてます

【CocoaPods】ライブラリ更新で [!] The `XXXXX.podspec` specification does not validate. エラーが出た時の原因

pod trunk pushでCocoaPodsライブラリのアップデートをしようとした時に表題のエラーが出た時の対処法です。 新バージョンに対応するgitのtagを更新していない可能性があるのでtagを付けてpushします。